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JRDS Error - An error has occurred processing your request / Provider cannot be found


Overview

When using the Jet Excel Add-In with SQL Server 2012/2014, and testing the connection to a Jet Remote Data Service ("JRDS")  data source, the following error message is displayed:

error_msg.png

Complete text of error message is:

An error has occurred processing your request to the data source.

When a Jet Excel Add-In Log file is created, the log file contains the message "Provider cannot be found.  It may not be properly installed."

Cause

This error is generally encountered when either

  • the SQL Server Native Client driver (aka "provider") is not installed or
  • the driver present on the server is not fully compatible with the version of SQL Server that is installed.

Resolution

Installing the compatible SQL Server Native Client (on the server containing the JRDS and Microsoft's IIS) should resolve the issue.

Once the installation is complete, restart Microsoft Excel and test the connection again.

SQL Server Clients are available directly from Microsoft.  For example, here is a link to Microsoft's SQL Server 2012 Feature Pack: http://www.microsoft.com/en-us/download/details.aspx?id=29065

  1. Once viewing that page, expand "Install Instructions"

  2. Scroll down to the section titled "MICROSOFT SQL SERVER CONNECTIVITY FEATURE PACK COMPONENTS".

    Then, download and install the "Microsoft SQL Server 2012 Native Client" that is appropriate for your installation of WIndows ( x86 = 32-bit, X64 = 64-bit)

     

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