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Error: E_ACCESSDENIED or "The type initializer for 'Jet.Data.JetDataSourceFactory' threw an exception"


Overview

When attempting to upload a report to the Jet Hub, an error message is displayed:

jwperror01.png

or when attempting to run a report within the Jet Hub, the report is unable to complete and the following message is logged:

jwperror02.png

Complete text of error message is:

The type initializer for 'Jet.Data.JetDataSourceFactory' threw an exception.

or

System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
     at d.a(Stream A_0, String& A_1, String A_2)    at Jet.Nimbus.Application.Workers.ReportRunner.RunReport2()

 

Cause:

An issue was recently identified that is a result of one of the automatic Windows Updates that Microsoft released between July 10th-13th.  This issue affects Windows 10 and Windows Server 2012 environments that host the Jet Service Tier, where the updates have been installed.

Resolution:

Microsoft has released a manually-installable update to resolve the issues caused by the July 10th Microsoft Security and Microsoft .NET updates when working with the Jet Service Tier and Jet Hub.  You can download the applicable update for your version of Microsoft Windows or Windows Server in the Resolution section of the Microsoft Support article.

You must install this update on the server where your Jet Service Tier service is running in 'services.msc' and restart the server to resolve the issue.

Resolution Process

  1. Navigate to the Microsoft Support article and scroll down to the Resolution section

    jwperror03.png

  2. Click on the Microsoft KB number (e.g., 4346742) corresponding to your specific Windows Operating System and version of the .NET Framework 

  3. Scroll down to the section titled How to get this update and click the link for the Microsoft Update Catalog

    jwperror04.png

  4. Click the Download link for your matching Windows OS and .NET Framework version

    jwperror05.png

  5. Click the link provided in the Microsoft Download Dialog

    jwperror06.png

  6. Once the installer is downloaded in your browser, run it

    jwperror07.png

  7. When prompted to install, select Yes

    jwperror08.png

    Note: If a message appears informing you that the update is not applicable to your computer, you'll need to go back to the Microsoft Support article and select the correct link for your Windows OS and version of .NET Framework.

    jwperror09.png

  8. When prompted, accept the Microsoft License Terms

    jwperror10.png

    and allow the installation to complete:

    jwperror11.png

  9. Restart the server

    The server will need to be restarted to complete the installation.

    You can elect to restart the server, now, or close the installer and perform a manual restart later.

    jwperror12.png


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