Overview
When attempting to access your Dynamics 365 Business Central data using either Jet Reports or Jet Reports Financials, a message is displayed:
Complete text from error message:
You are not authorized to access this data source. You must sign-in using your Office 365 credentials for authorization.
Cause:
This error message is caused when the password for your Office 365 account has changed since you established your data source settings.
Resolution Process
-
Using Jet Reports
Access the Data Source Settings for your Business Central data source.
Click Log out
Click Log in
When prompted, log in to your Office 365 account.
-
Using Jet Reports Financials
- Close Excel completely (ensure that no EXCEL.EXE processes are running in Windows Task Manager)
- Open Windows Explorer, type %appdata% in the address bar and press enter
This will bring you to your roaming profile folder C:\Users\username\AppData\Roaming\
Rename the Jet Reports folder to Jet Reports OLD - Close Windows Explorer
- Open Excel
- Sign into your Business Central account when prompted
- Test to ensure that the issue is resolved
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