0

Performance Issue with calculated Fields

Hi at all,

wit the following Jet-Code in Excel I receive a Performance, that's really horrable… I hope to know where the Problem is. I ask values from two databases, out of Item Entry Table like follows:

=NL("Zeilen";"94001 Alte Artikelposten";;"Schlüssel=";{"2 Artikelnr."."94010 Debitorennr."."3 Buchungsdatum"."33 Kostenstellencode"."1 Lfd. Nr."};"2 Artikelnr.";$G15;"94010 Debitorennr.";$C$2;"3 Buchungsdatum";$C$3;"Kostenstellencode";$C$4) =NL("Zeilen";"32 Artikelposten";;"Schlüssel=";{"2 Artikelnr."."94010 Debitorennr."."3 Buchungsdatum"."33 Kostenstelle Code"."1 Lfd. Nr."};"2 Artikelnr.";$G15;"94010 Debitorennr.";$C$2;"3 Buchungsdatum";$C$3;"Kostenstelle code";$C$4)
The cells I ask with the following Code:
=WENNFEHLER(NF($H16;"12 Menge")*-1;0)
And I think, this is the Problem. If I leave "*-1" and "WENNFEHLER", Excel is ready in seconds. If I run those two Operators, Excel is VERY slow. We talk about >20 minutes für 200.000 lines.
These two lines are a Group and I build a sum over the values like this:



Has anybody any idea how to solve this?
Thanks so much in advance!

Kind regards
Marit

1 comment

Please sign in to leave a comment.